Workday Service Interruption

Resolved

Service has been restored for all Workday Data Centers. Customers are now able to login and use production and implementation tenants as expected.
Posted Mar 17, 2025 - 15:22 CDT

Monitoring

Access to Workday has been restored for the majority of users, with many across the UA System reporting they can now access again. Workday acknowledges that a subset of users may still be unable to login. An additional update will be provided at 3:00 p.m. CT
Posted Mar 17, 2025 - 14:38 CDT

Update

Workday is aware of the performance issues impacting all data centers. A root cause is working to be identified and an update is expected to be provided at 2:30 CT.
Posted Mar 17, 2025 - 14:04 CDT

Investigating

Workday Support Services is aware of a service interruption to Workday Production and implementation tenants. A case has been opened with Workday and this incident will be updated once more information is available.
Posted Mar 17, 2025 - 13:56 CDT
This incident affected: Workday Services (Workday - Production Tenant, Workday - Training Tenant - SBX).