Workday Production Tenant - High Processing Times

Resolved

The Workday Production tenant has been restored to normal processing times. We are reviewing any processes and integrations that may have failed during this time and will be reaching out to institutions if action is needed. We apologize for the inconvenience.
Posted May 22, 2024 - 11:26 CDT

Identified

Workday Support Services is aware that Workday is experiencing high queue times on many submitted processes. We are working to resolve the background processes that are causing these high queue times. In the meantime, please do not submit processes multiple times. We will provide an update shortly.
Posted May 22, 2024 - 09:54 CDT
This incident affected: Workday Services (Workday - Production Tenant).